I've got two hosts (vhost1 = ESX 4.0 , vhost2 = ESX 5.5) both are setup for teaming and both connected to an Adtran 1544 L3 switch (named sw01). vhost1 has been in production for several years with the config below and has been rock solid. I'm trying to duplicate the teaming/bonding setup on vhost2 and it doesn't work when teamed but will work when using a single nic (w/out teaming).
To be more specific on what doesn't work, both vhosts have "Server Network" (vlan 8) defined as a port group. Both physical and viritual servers on the same vlan can not ping or resolve arp requests for VMs on vhost2. Anything that is routed from a different subnet can connect to VMs on either vhost.
So the question is this: Why isn't ESX 5.5 working like ESX 4.0 when the configs are as close to identical as I can make them and they're connected to the very same switch?
Thanks for any input you can provide!
-S
Here's the setup for vhost1
switch 1 (sw01)
sw01#sho run int port 3
Building configuration...
!
!
interface port-channel 3
description LAG for vhost1
no shutdown
switchport mode trunk
switchport trunk allowed vlan 1,8
!
end
sw01#sho run int gig 0/23
Building configuration...
!
!
interface gigabit-switchport 0/23
description vhost1 vmnic2-vswitch1
no shutdown
channel-group 3 mode on
!
end
sw01#sho run int gig 0/24
Building configuration...
!
!
interface gigabit-switchport 0/24
description vhost1 vmnic1-vswitch1
no shutdown
channel-group 3 mode on
!
end
vhost1
[root@vhost1 ~]# esxcfg-nics -l
Name PCI Driver Link Speed Duplex MAC Address MTU Description
vmnic0 03:04.00 tg3 Up 1000Mbps Full 78:e7:d1:5f:01:f4 1500 Broadcom Corporation NC326i PCIe Dual Port Gigabit Server Adapter
vmnic1 03:04.01 tg3 Up 1000Mbps Full 78:e7:d1:5f:01:f5 1500 Broadcom Corporation NC326i PCIe Dual Port Gigabit Server Adapter
[root@vhost1 ~]# esxcfg-vmknic -l
Interface Port Group/DVPort IP Family IP Address Netmask Broadcast MAC Address MTU TSO MSS Enabled Type
vmk1 VMkernel - Server NetIPv4 10.1.8.31 255.255.255.0 10.1.8.255 00:50:56:78:9e:7e 1500 65535 true STATIC
vmk0 VMkernel - SAN Net IPv4 10.1.252.20 255.255.255.0 10.1.252.255 00:50:56:7c:d8:7e 9000 65535 true STATIC
[root@vhost1 ~]# esxcfg-vswif -l
Name Port Group/DVPort IP Family IP Address Netmask Broadcast Enabled TYPE
vswif1 Service Console - Management NetIPv4 10.1.1.12 255.255.255.0 10.1.1.255 true STATIC
[root@vhost1 ~]# esxcfg-vswitch -l
Switch Name Num Ports Used Ports Configured Ports MTU Uplinks
vSwitch0 32 4 32 1500
PortGroup Name VLAN ID Used Ports Uplinks
VM Network 0 3
Switch Name Num Ports Used Ports Configured Ports MTU Uplinks
vSwitch1 64 12 64 1500 vmnic1,vmnic0
PortGroup Name VLAN ID Used Ports Uplinks
Server Network 8 7 vmnic1,vmnic0
Service Console - Management Net0 1 vmnic1,vmnic0
VMkernel - Server Net8 1 vmnic1,vmnic0
On the vSwitch Load Balancing it set to IP Hash.
Here's the setup for vhost2
switch 1
sw01#sho run int port 4
Building configuration...
!
!
interface port-channel 4
description LAG for vhost2
no shutdown
switchport mode trunk
switchport trunk allowed vlan 1,8
!
end
sw01#sho run int gig 0/17
Building configuration...
!
!
interface gigabit-switchport 0/17
description vhost2
no shutdown
channel-group 4 mode on
!
end
sw01#sho run int gig 0/18
Building configuration...
!
!
interface gigabit-switchport 0/18
description vhost2
no shutdown
channel-group 4 mode on
!
end
vhost2
~ # esxcfg-nics -l
Name PCI Driver Link Speed Duplex MAC Address MTU Description
vmnic0 0000:08:00.00 e1000e Up 1000Mbps Full 00:25:90:e7:0e:9c 1500 Intel Corporation 82574L Gigabit Network Connection
vmnic1 0000:09:00.00 e1000e Up 1000Mbps Full 00:25:90:e7:0e:9d 1500 Intel Corporation 82574L Gigabit Network Connection
~ # esxcfg-vmknic -l
Interface Port Group/DVPort IP Family IP Address Netmask Broadcast MAC Address MTU TSO MSS Enabled Type
vmk0 Management Network IPv4 10.1.1.15 255.255.255.0 10.1.1.255 00:25:90:e7:0e:9c 1500 65535 true STATIC
~ # esxcfg-route -l
VMkernel Routes:
Network Netmask Gateway Interface
10.1.1.0 255.255.255.0 Local Subnet vmk0
default 0.0.0.0 10.1.1.1 vmk0
~ # esxcfg-route -n
Neighbor MAC Address Interface Expiry Type
10.1.1.1 00:a0:c8:8a:ff:3b vmk0 19m13s Unknown
~ # esxcfg-vswitch -l
Switch Name Num Ports Used Ports Configured Ports MTU Uplinks
vSwitch0 4352 7 128 1500 vmnic0,vmnic1
PortGroup Name VLAN ID Used Ports Uplinks
Server Network 8 1 vmnic0,vmnic1
Management Network 0 1 vmnic0,vmnic1
On the vSwitch Load Balancing it set to IP Hash.